Lexonik Courses

Technical requirements

Your course can be taken on any devices that support the browsers listed below. Some earlier versions may also be compatible, but you may experience limited functionality.

This includes mobile devices such as smartphones and tablets including iPads, iPhones and android devices. 

You should ensure that your device’s operating system and browser is kept up to date for the best experience.

Google Chrome (latest version)

Microsoft Edge (Chromium based, latest version)

Internet Explorer 11

Firefox (latest version)

Google Chrome (latest version)

Safari (latest version)

Firefox (latest version)

Safari in Apple iOS 12 or later

Google Chrome (latest version) in Apple iOS 12 or later

Google Chrome (latest version) in Android OS 6 or later